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CNC Milling 

WORKING WITH THE ATC 

Name Class/Period Date 

   

1. Overview 

This tutorial teaches you how to use your machine’s automatic tool changer (ATC), both in CNCMotion 
and with the machine itself.  

2. Performance Objectives 

After completing these hardware tasks, you will be able to: 

• Configure the ATC. 

• Define ATC station locations.  

• Initialize ATC station locations.  

• Switch tools using the ATC.  

• Run a program with multiple tools where tool switching is performed automatically by the ATC.  

3. Required Materials 

You need these materials to complete the hardware tasks:  

• CNC milling center with installed mechanical vice and ATC 

• Connected computer with CNCMotion 

• 1/8 inch or 3 mm end mill (in a tool holder) 

• 3/8 inch or 10 mm end mill (in a tool holder) 

• Two empty tool holders 

• Hex Allen wrench set 
• Machinable workpiece 

• Safety goggles 

4.  Safety and Inventory Checks  

Before beginning the hardware task, review this checklist. 

 Ensure that your lab station passes the safety guidelines.  

 Complete the inventory and safety checklists for your lab station. 

 If there is a tool in the spindle and you need to construct a vice, remove the tool before 
constructing the vise.  

 You have read through the entirety of this lab activity to familiarize yourself with the 
requirements. 
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5. Working with the ATC in CNCMotion 

Perform this section’s tasks in CNCMotion before using the ATC on a physical machine. 

5.1. Installing the ATC 

Your machine’s default configuration does not have an ATC. Perform the steps below to install the ATC 
into the virtual machine.  

If your virtual machine has an ATC, skip to Section 5.2 Preparing the ATC on page 7. 

1. Close CNCMotion if it is running.  

2. In your computer’s Start or Program menu, open the CNCMotion Configuration app.  

 

The CNC Configuration window for your machine is displayed. The BenchMill 6100’s is shown 

here.  
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3. Select the Options tab.  

 

4. Before adding an ATC, the power drawbar must be deactivated. Select Power Drawbar Control.  
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5. Click Remove.  

 

6. In the confirmation window, select Yes.  
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The power drawbar is removed from the Installed Options.  

 

7. Click Reinstall. 

 

8. The Reinstall Options window is displayed. Select the Table-Mounted ATC and then click 

Reinstall.  
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The ATC is added to the Installed Options.  

 

9. Click OK.  

 

10. A popup window is displayed. Click Yes to run CNCMotion.  

 

11. CNCMotion opens. The ATC is inside the machine envelope.  
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5.2. Preparing the ATC 

In this task, you will add tools to the first two stations of the ATC and initialize the locations of all four of 
the stations.  

Perform these steps: 

1. Close the safety shield / door.  

2. From the menu, select Tools > Setup Library.  

 

3. Configure the following tools:  

▪ Tool 1 – A 0.125’ / 3 mm endmill. Set the Station to 1.  
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▪ Tool 2 – A 0.375’ / 10 mm endmill. Set the Station to 2. 

 

4. Navigate to Tools > Configure ATC.  
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The Configure ATC window is displayed. Tool 1 is in Station 1 and the spindle is empty.  

 

5. Select Station 2.  
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6. From the Tool In This Station dropdown menu, select Tool 2.  

 

7. Click OK to confirm the changes and close the window.  
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8. In the 3D graphic window, ensure that the two tools have been equipped onto the ATC and that 

the spindle is empty.  

 

In the next steps, you will send the spindle to the ATC tool station locations and initialize those 

locations so they are usable during machine operation.  

9. Home the machine. 

10. From the menu, select 3D Image > Send Machine > ATC Station 1.  

 

The machine moves to Station 1. Note that when using the actual machine in Section 6, you will 

need to jog the machine to the tool holder in the station.  
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11. Select Tools > Initialize Station Location > Station 1.  

 

12. A confirmation window is displayed. Select Yes.  

 

13. The station is initialized. Click OK to close the window.  

 

14. Repeat steps 10 to 13 for Stations 2, 3, and 4.  



  
 

13 

  
 

CNC Milling|Working with the ATC 

 © 2024 Intelitek Inc. All rights reserved | CNC_Milling_ATC_v1.1 

 

5.3. Switching Tools 

In this task, you will use the ATC to switch between the two tools. Perform these steps: 

1. Tool 1 will be equipped first. Select Tools > Insert/Remove Tool from > Station 1. 

 

2. In the confirmation popup, select Yes.  
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The machine moves to Station 1 and mounts Tool 1. It then returns to the initial spindle position 

(which was the home position).  

 

3. You will now equip the machine with Tool 2. Select Tools > Insert/Remove Tool from > Station 2. 

 

4. In the confirmation popup, select Yes.  
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The machine moves to Station 1 to return Tool 1. It then moves to Station 2 and mounts Tool 2. It 

then returns to the home position.  

 

5. Return Tool 2 to the ATC. Select Tools > Insert/Remove Tool from > Station 2. 
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6. In the confirmation popup, select Yes.  

 

The tool is returned to Station 2, and the machine returns to the Home position without any 

tools in the spindle.  

 

 Note: Another way to insert/remove tools is to use the tool change feature in the CNCMotion 

Toolbar.  
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5.4. Running a Program with the ATC 

In this task, you will prepare and run the House program that you created in Activity 10. Because the 
ATC is active and the station locations have been initialized, tool switching is performed automatically 
during an M06 command.  

Perform these steps: 

1. Load the House program.  

 

 

2. Equip the spindle with Tool 1. Select Tools > Insert/Remove Tool from > Station 1. In the 

confirmation popup, select Yes.  

3. From the toolbar, click the Send Tool to Corner icon.  

 

4. Click the near corner of the machine.  
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The machine moves the tool tip to the corner.  

 

5. Select Setup > Zero Position to set this position as the origin (0,0,0).  
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6. You will now set the position for a dry run. Select Setup > Goto Position.  

 

7. Enter the following coordinates in the dialog box:  

Imperial Metric 

  

8. Select Setup > Zero Position to set this position as the origin.  

9. Click the Run button. 
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10. The Run Program window opens. Click Run Program.  

 

11. Ensure that the program runs with the tooltip 1 inch / 25 mm above the workpiece. Note how 

the tools are changed automatically during the program run. 

 



  
 

21 

  
 

CNC Milling|Working with the ATC 

 © 2024 Intelitek Inc. All rights reserved | CNC_Milling_ATC_v1.1 

 

12. Once the program competes, send the tooltip to the origin (which is now 1 inch / 25 mm above 

the near corner of the workpiece).  

13. Set the position as 0,0,1 (for Imperial) or 0,0,25 (for metric). This returns the origin to the corner 

of the workpiece.  

14. Run the program to completion. Ensure that it executes as expected.  
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6. Hardware Tasks 

6.1. Preparing the ATC 

 Note: The 4-Station ATC must already be installed in your machine (preferably by an Intelitek 

technician) before beginning any hardware tasks. Assembly instructions can be found here.  

 Note: If required, review previous activities and hardware tasks for any procedures that are not 

described in full. 

Follow the steps below to prepare the ATC.  

1. If the CNCMotion or CNCBase software at the machine workstation is not where you performed 

the offline tasks, and the ATC is not already configured, perform the steps in Section 5.1 

Installing the ATC. 

2. Ensure that the Emergency Stop button is released. 

3. Turn on the power switch. 

4. Ensure that the control software is connected to the mill (Setup > On-Line). 

5. Close the safety shield.  

6. Home the machine.  

7. Open the safety shield. 

8. If there is a tool holder in the spindle, remove it.  

9. Secure Tool 01, the thinner end-mill, in a tool holder and insert the tool holder into Station 1 

(the frontmost station) of the ATC. The ridges of the tool holder should fit securely in the knobs 

of the station as shown on the next page.  

https://downloads.intelitek.com/Manuals/CNC/Accessories/ATC_6000-8000-B.pdf
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10. Open the Setup Tool Library (Tools > Setup Library) and confirm that Tool 01 is defined as the 

end mill that you installed. In the Station field, enter 1.  

11. Secure Tool 02, the thicker end-mill, in a tool holder and insert the tool holder into Station 2 of 

the ATC. 

12. In the Setup Tool Library, define Tool 02 as the large end mill. In the Station field, enter 2. 

13. Insert empty tool holders (or tool holders with other tools) into Stations 3 and 4.  

14. Close the safety shield. 

15. Navigate to Tools > Configure ATC. Configure the two tools as you did in Section 5.2 Preparing 

the ATC.  

16. Jog the spindle over Station 1 on the ATC. 

17. Slowly lower the spindle over the tool holder for Station 1. The tool holder should be centered in 

the spindle. Watch the gap between the spindle and the tool holder. Adjust the cross-slide’s X 

and Y positioning accordingly. 
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18. When the spindle is half-way down the tool holder, press and hold the green button to open the 

drawbar. With the drawbar button being pushed to hold the drawbar open, continue to lower 

the spindle over the tool holder. Continue to make X and Y axis adjustments, keeping the spindle 

centered on the tool holder. When the springs start to collapse, stop movement of the Z-axis. 

Release the drawbar button to clamp the tool. 

 

Click or scan this QR code to watch a video of the above step.  

19. In the software, select Tools > Initialize Station Location > Station 1. In the confirmation 

window, click Yes.  

20. Hold the green drawbar button and move the spindle upwards, away from the tool holder in 

Station 1.   

21. Repeat steps 16 to 20 for the other three stations.  

22. Close the safety shield.  

 Warning: You will now test the ATC. Be ready to press the Emergency Stop button in case you need 

to prevent crashes.  

23. Select Tools > Insert/Remove Tool from > Station 1. In the confirmation popup, select Yes. 

The machine moves to Station 1 and mounts Tool 1.  

24. Select Tools > Insert/Remove Tool from > Station 2. In the confirmation popup, select Yes. 

25. The machine moves to Station 1 to return Tool 1. It then moves to Station 2 and mounts Tool 2. 

26. Select Tools > Insert/Remove Tool from > Station 1. In the confirmation popup, select Yes. The 

machine returns Tool 2 and inserts Tool 1.  

https://tinyurl.com/2crxelwu
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6.2. Preparing the Machine and Workpiece 

In this task you will prepare the other elements of the machine setup. Perform the following:  

1. Secure a workpiece to the vise. 

2. Touch off the top of the stock using a piece of paper as you normally would before setting the Z-

axis to 0.  

 

3. Set the Z-axis position to 0 (Setup > Set Axis to Zero). 
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6.3. Defining the Tool Offset 

Perform these steps to define the tool offset for Tool 2.  

1. Using the ATC, equip the spindle with Tool 2 (Tools > Insert/Remove Tool from > Station 2).  

2. Touch off the top of the stock using a piece of paper as you normally would before setting the Z-

axis to 0. Do NOT zero the axis yet.  

At this point, the absolute Z-axis position will not be 0, because the tools will have different 

heights. 

3. Navigate to the Setup Tool Library (Tools > Setup Library), where Tool 02 is selected.  

4. Click Current Z.  

 

5. Click OK.  

6. Ensure that in the Actual Position window, the absolute Z-axis position is now 0.  

Imperial Example Metric Example 

  

7. Using the ATC, equip the spindle with tool 1. 
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8.  In the Machine Info window, ensure that Tool 01, the thinner end mill, is active. 

9. Touch off the front and left faces of the workpiece, and zero those axes to complete definition of 

the workpiece origin.  

10. Verify the workplace origin by sending the tool tip to a location directly above the origin. Keep 

your hand on the Emergency Stop button to prevent any potential accidents.  

6.4. Preparing for the Dry Run 

Follow the steps below to prepare the machine for the dry run. 

1. Open (File > Open) the House NC program that you completed in activity 10.  

You will now set the workpiece origin as 1 inch / 25 mm above the top-front-left corner of the stock so 
that when the program is run for the dry run, the tool will operate above the workpiece.  

2. Navigate to Setup > Goto Position and enter the following coordinates in the dialog box:  

Imperial Metric 

  

3. With one hand on the Emergency Stop button to prevent potential accidents, click GO to send 

the tool to the defined position above the point-of-origin.  

4. Select Setup > Set Position to display the Set Position dialog box. Enter the coordinates (0, 0, 0) 

and then click OK to reset the point-of-origin to the current position. 
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6.5. Performing the Dry Run 

Follow the steps to perform the dry run: 

1. Select Program > Run/Continue or click the green Run icon  on the toolbar.  

 

The Run Program dialog box is displayed. 

 Note: In the next step you will run the program. Watch the tool motion in relation to the vise and 

the workpiece. 

2. With one hand on the Emergency Stop button, click Run Program. Look for signs of a possible 

tool crash with the hardware or stock and be prepared to prevent any crashes by pressing the 

Emergency Stop button. 

 

When the program reaches the second tool change command, the cross-slide stops moving, and 

the spindle stops rotating. The spindle moves automatically to the ATC and returns Tool 1. It then 

installs Tool 2.  

3. Confirm that the program executes correctly above the workpiece without striking the hardware 

and that the tool changes occur automatically without error. 

▪ If you are satisfied with the program execution, continue to the next section. 

▪ If there are any problems, make the necessary corrections and rerun the dry run until the 

program executes correctly. 
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6.6. Resetting the Origin 

You will now reset the workpiece origin to the top-front-left corner of the stock in preparation for actual 
machining.  

1. Navigate to Setup > Go to Position and enter the coordinates (0, 0, 0).  

2. With your hand on the Emergency Stop button to prevent potential accidents, click GO to send 

the tool to the position currently defined as the point-of-origin. As required for the dry run, this 

position is 1 inch / 25 mm above the origin. 

3. Navigate to Setup > Set Position. Enter the coordinates shown below and then click OK.  

Imperial Metric 

  

This resets the position to its true coordinates and restores the original workpiece origin. 
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6.7. Machining the Part 

You will now observe the machining center cutting the part. Remember that when working with a 
machining center, safety is of the highest importance. You are expected to be ready to instantly stop the 
machine should any problems arise. 

Perform this procedure to machine the part: 

1. Put on your safety goggles.  

2. In the Operator Panel, set both the Spindle Override and Feed Override to 100%. This ensures 

that the spindle speed and feed rate will be exactly as defined in the NC program. 

 

3. Select Program > Run/Continue or click the Run icon  on the toolbar. The Run Program dialog 

box is displayed. 

4. Click Run Program. 

 

Note that even though the program starts with Tool 2 mounted in the spindle, the first M06 

command instructs the machine to use the ATC to return Tool 2 and insert Tool 1.  

5. Confirm that the program executes correctly with tool changes being performed automatically. 

▪ If you are satisfied with the program execution, continue. 

▪ If there are any problems, make any necessary corrections and rerun the program until it 

executes correctly. 
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7. Authentic Skills Assessment 

Have your instructor verify that your work meets the requirements in the Performance Objectives and 
sign below. Keep this hardware task sheet for future reference. 

Instructor Signature Date 

  

8. Inventory and Shutdown  

Unless instructed otherwise by your instructor, complete each of the steps below.  

1. Home the mill. 

2. Open the safety shield. 

3. Use the ATC to return tool 2 back to station 2.  

4. Store the step clamp and hex wrenches away. 

5. Use a dry brush to clear any chips from the vise and cross-slide. 

6. Switch off the machine power. 

7. Exit the iCNC control software. 
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