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Robotics, Integration, and Automation 

BUILDING THE SMARTCART INTERFACE 

Name Class/Period Date 

   

1. Overview 

In this lab activity, you will create an HMI (Human Machine Interface) that initiates and monitors the 
robot job sequence that you programmed in the previous section.   

2. Performance Objectives 

After completing this lab activity, you will be able to: 

• Reset the HMI screen to factory defaults (excluding firmware version).  

• Define the HMI screen’s IP address.  

• Create an HMI Project. 

• Build a basic screen hierarchy.  

• Bind PLC tags to graphic elements. 

• Add the HMI screen to the factory LAN. 

• Protect high level security screens with a password.  

3. Required Materials 

You need the following materials to complete the lab activity:  

• SmartCart 4.0 

• Computer 

• Ethernet cables 

4. Required Software 

Logix Designer and View Designer are required for this lab activity. They are included in the Studio 5000 
suite. Ensure that Studio 5000 is installed on your PC and has a valid license. If you are having problems 
installing or licensing the software, contact your instructor or IT manager.  

5. Inventory and Safety 

Before beginning the lab activity, review this checklist and mark off each item as you complete it. 

 All hardware components are available for this lab activity.  

 Hands, hair, and clothing are securely away from the work area. 

 The work area is clean and devoid of food or drink. 

 Review the SmartCart safety guidelines. 

 Read through the entirety of this lab activity to familiarize yourself with the requirements. 
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6. Lab Activity  

6.1. Adding the HMI Screen to the LAN 

In order for your HMI to communicate with your computer and the CompactLogix controller, it must be 
given an IP address on the same subnet as the other devices. In this task, you will restore the HMI to its 
default state and then assign it a static IP address: 

1. Ensure that your workstation, the PLC, the robot, and the HMI are connected to the switch via 

Ethernet cables.  

 Note: If your HMI screen has never been used before, it requires a firmware update. For first time 

use of the HMI and the procedure for updating the firmware, see Appendix: Updating HMI 

Firmware on page 45. 

2. Power on the I/O box. The HMI and PLC power on. During startup of the HMI terminal, the Allen-

Bradley logo is displayed.  

3. Wait several seconds. When the copyright line becomes brighter, press the Allen-Bradly logo.  

 Note: Error text is displayed if you tap the logo too soon. In this event, power the I/O box off and 

then return to step 2. 

4. Two warning messages are displayed, asking you to confirm the reset. For both messages, press 

Yes.  

Progress messages appear on the screen during the restore operation. When the restore is 

complete, the startup menu is displayed.  

5. Press Network to access the Network menu.  

6. The Internet Protocol (IP) Settings are displayed. Select Manually configure IP settings.   

7. Press the IP address and change it to 192.168.0.4. Press OK to confirm the changes.  

8. Set Subnet Mask to 255.255.255.0.  

9. Press the X button to exit the Network settings. 

10. On your workstation, open Windows Command Prompt. Ping 192.168.0.4 and confirm network 

connectivity. Troubleshoot your LAN setup if the ping was unsuccessful. 
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6.2. Creating a New Project 

In this task, you will create a new View Designer project and set the project’s communication path so 
that the HMI can talk to the PLC.   

Perform these steps.  

1. Launch Studio 5000.  

 

2. A Studio 5000 menu opens. In the Create area, select New Project.  
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3. In Project Types on the left side, select View. In the controller menu on the right side, select your 

PanelView device.  

 

4. Give your project a good name, and then click Finish.  
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View Designer opens and the Project Properties window is displayed with the References tab open. In 
these next steps, you will configure the path between the controller (PLC) and the HMI.  
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5. In the Controller Reference Name field, enter the name of your PLC from the Logix Designer 

project you saved at the end of the previous lab activity. If necessary, open the Logix project and 

view the name of the PLC.    

 

6. Click the ellipsis (three dot) button next to the Logix Project File field. Browse to and then select 

the Logix project’s ACD file, the file you saved at the end of the previous lab activity.  
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7. Click the ellipsis button next to HMI to Controller Path. 

 

8. A FactoryTalk browser opens. Browse to and select your controller. Click OK to close the browser 

window. 

 

 Note: Your FactoryTalk browser window may show other devices if they are powered on and on 

the SmartCart LAN. 

9. Click the ellipsis button next to the Emulator to Controller Path. An emulator allows you to test 

your View Designer project on your workstation without an HMI screen. However, connection to 

the PLC is necessary.  
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10. In the browser window, again select your PLC. Click OK to close the browser window. 

The path to the PLC is displayed in the Emulator to Controller Path field.  

 

11. In the Project Properties window, select the Application tab.  

 

12. Click the ellipsis button next to the Location field.  
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13. Browse to and select your HMI panel. Click OK to close the window.  

 

14. Click OK to close the Project Properties window.  

 

 Note: You can return to the Project Properties window from the main menu at any time by 

selecting Project > Project Properties.  
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The Project Explorer on the left side shows the various screens of the project. The Navigation 

Menu has a list of shortcuts that the user can select from the onscreen menu (by pressing the 

 button) to reach the various predefined screens.  
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6.3. Screen Navigation 

In this task, you will set up a basic screen hierarchy. After creating a second screen (a dashboard screen 
for the system integrator or operator), you will add controls so that a user can navigate between the 
Home screen and the dashboard screen.  

Perform these steps:  

1. In the Project Explorer, change the name of Screen_001 to Home in both the Navigation Menu 

folder and the User-Defined Screens folder. To rename a screen, select the screen and then press 

F2 on your keyboard.  

 

2. Right-click the User-Defined Screens folder. In the popup list, select New Screen.  
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3. Change the name of the screen to Dashboard. 

 

4. Double-click the Home screen to open it in the main work area.  

 

5. In the Toolbox, select the CommonControls category. 

 

6. Double-click Button to add a button to the Home screen.  

 

 Note: If the contents of the category are not displayed in the toolbox, drag the bottom section of 

the Toolbox window upwards.  
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7. Double-click the button to edit its text label.  

8. Change the text label to Dashboard.  

 

9. Select the button.  

 

10. In the Properties window, select the Events tab. 

 

11. From the Add Event dropdown menu, select Touch Press. This means that the event will occur as 

soon as the button is pressed.  

 

The Touch Press event is added.  
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12. From the Add Command dropdown menu, select Navigation > Screen Navigate.  

 

The Navigate To command is added to the event.  

 

13. In the empty dropdown menu, select User-Defined Screens > Dashboard.  
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The command is completed. Once the runtime application is downloaded to the HMI, this 

button will navigate the user to the dashboard screen.  

 

14. Copy the button (Ctrl +C).  

 

15. In the Project Explorer, double-click Dashboard to navigate to that screen.  
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16. Paste the button (Ctrl + V) onto the screen.  

 

17. Change the button’s text label to Home. Drag the button to one of the corners.  

 

 Note: Feel free to make graphic adjustments (colors, styles, etc.) at any time.   
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18. Select the button. In the Properties window, modify the Navigate To event so that the button 

navigates the user to the Home screen.  

 

You will now download the View Designer project to the HMI to test the navigation controls.  

19. In the menu at the top of the interface, select Project > Verify Project.  

 

20. The Verify Project window is displayed. Ensure that there are no errors or warnings. 

 

21. Close the Verify Project window.  
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22. Select Communications > Download.  

 

23. The Download Runtime Application window is displayed. Click Download.  

 

The project’s runtime application is downloaded to the HMI, and the Home screen is displayed 

on the device.  
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 Note: The images below were taken from an emulator. Perform this task on the HMI.  

24. The Home screen is initially displayed. Press the Dashboard button to navigate to the Dashboard 

screen.  

 

25. Press the Home button to return to the Home page.  

 

26. Troubleshoot your project if the navigation does not work properly. 
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6.4. Binding Tags 

In this task, you will create additional graphic elements and then bind those elements to tags in the 
Logix project.  

Perform these steps:  

1. Add a new button to the Dashboard screen. Change its text to Start.  

 

2. Select the new button. In the button’s Properties window, add a Button Behavior event (Add 

Event > Button Behavior).  
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3. In the Choose Behavior dropdown list, select Set a tag to 1 on press, 0 on release.  

 

4. The Tag field is displayed. Click the ellipsis button next to the empty field.  

 

5. The tag browser window opens. Select your PLC.  

 



  
 

22 

 
 

Robotics, Integration, and Automation|Building the SmartCart Interface 

 © 2023 Intelitek Inc. All rights reserved | RAI_4-2_Building_HMI_v1.71 

 

6. Browse to the Start BOOL tag and double-click it.  

 

The PLC tag is added to the button behavior event. Now, whenever the button is pressed, the 

Start tag will be on (value of 1). Whenever it is released, the tag will be off (0). Pressing the 

button on a screen is a much more efficient way of initializing the robot jobs as opposed to 

having to toggle an instruction in a ladder diagram. 

 

7. Select the button. Press Ctrl + D on your keyboard to duplicate the button.  
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8. Relocate the buttons to the left side.  

 

9. Change the text of the second button to Reset.  
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10. Select the Reset button. In the Properties window, click the Tag ellipsis button and then change 

the bound tag to the Reset tag.  

 

1 

2 
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11. In the Toolbox, double-click Text Display to add a textbox to the screen.  

 

12. Duplicate the text displays. Ensure that there is a text display for each of the jobs that are 

initiated via the Logix Project. In the next steps, you will add animated arrows that will indicate 

which job is currently executing.  
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13. In the Toolbox search field, enter arrow.  

 

14. From the search results, double-click Left Arrow 1 to add it to the screen.  

 

15. Drag the arrow next to the first job’s textbox. Increase the size of the arrow by dragging one of 

its corners.  
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16. Select the arrow. In its Properties window, change the FillColor so that the element is clearly 

visible.  

 

17. With the arrow still selected, click the Animations tab. 
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18. In the Add Animation dropdown list, select State Table.  

 

A State Table Definition window is displayed.  

 

19. Increase the number of states to 2. 
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20. In the Properties area, check the Visible option.  

 

21. Click OK. 

 

The state table is added to the animation.  
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22. Uncheck the Visible checkbox for State0.  

 

You have now created a state table animation for the arrow. There are two states, State0 and 

State1. When State0 is active, the arrow will be hidden. When State1 is active, the arrow will be 

visible. 

The animation now needs to be bound to a tag. When the tag is off (value = 0), the arrow will be 

in State0 (hidden). When the tag is on (value = 1), the arrow will be in State1 (visible). 

23. Click the ellipsis button next to the Expression (Enter binding) field.  
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24. Browse to and double-click the BOOL tag responsible for monitoring the start/stop status of the 

first pick and place job. 

 

The tag is bound to the state table animation.  

 

25. Duplicate the arrow twice. Relocate the arrows so that they are each next to a job.  
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26. Change the binding of the arrow’s animation to the BOOL tag responsible for monitoring the 

start/stop status of the second job. 

 

27. Do the same with the third arrow for the third job’s tag.  

 

28. Verify the project. Correct any errors.  

 

29. Save the project. 
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30. Download the project to the HMI. 

 

6.5. Testing the System 

In this task, you will use the HMI to initiate robot jobs and monitor their completion status. 

Perform these steps:  

1. Turn on the air compressor.  

2. Power on the robot. Wait for it to boot up.  

3. Ensure that the programming pendant mode key is set to Teach mode.  

4. Open the Logix Designer project if it is not already open. Download it to the PLC, and then go 

offline.   

5. On the pendant, navigate to JOB > SELECT JOB. Select the main project job.  

6. Turn the mode key to Play mode.  

7. Turn servo power on.  

 Warning: In the next step you will play the job. Ensure that all safety measures are in place.  

 Note: Workpieces are not required for this task.  

8. Press the green play button. The robot should not move, as it is waiting for input from the PLC 

(i.e., the Start tag turning on).   

9. On the HMI, press the Dashboard button to navigate to the dashboard screen.  
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10. Press the Start button.  

 

The robot begins to run the jobs in the order specified by the PLC routine. On the HMI, the arrow 

points to the job that is currently running.   
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11. Monitor the HMI screen and ensure that the arrow points to the job name/number that is 

actually being played.  

 

12. After job execution is completed, run the job again, start the sequence with the Start button, 

and then test the Reset button. 
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13. Make any desired graphical changes to the HMI screens. Verify, save, and test the View Designer 

project when you are done.  

 

6.6. Security 

In this task, you will add security measures to the project so that no unauthorized personnel can access 
the dashboard screen.  

Perform these steps:  

1. From the menu at the top, select Tools > Security Administration. 
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The Security Administration window is displayed.  

 

2. Add a new user with the Administrator role. Use a password that you will remember.  

 

3. Set the guest user role to Restricted.  
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4. Click OK to confirm.  

 

5. Click any empty area of the Dashboard screen. This selects the screen itself. The screen’s 

properties are displayed in the Properties window.  

6. In the Properties window’s Properties tab, click the arrow next to Security to expand the security 

settings for the screen.  

 

7. Change the Restricted user’s access level to No Access.  
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8. Save and verify the project.  

9. Download the project to the HMI.  

10. On the HMI screen, press the Dashboard button.  

 

The button disappears temporarily because it is restricted to guest users. You have yet to log on 

as an administrator. 

 

11. Click the Log on button in the menu at the top of the HMI screen.  

 

12. Enter the credentials that you set when creating the administrator user, and then press Log on.  

 



  
 

40 

 
 

Robotics, Integration, and Automation|Building the SmartCart Interface 

 © 2023 Intelitek Inc. All rights reserved | RAI_4-2_Building_HMI_v1.71 

 

You are now logged on as an administrator.  

 

13. Press the Dashboard button.  

 

This time you are granted access to the dashboard screen.  

 

When you tried to access the dashboard as a guest, you were denied access. It would make for a better 
user interface if a guest would get some sort of message explaining why pressing the Dashboard button 
does not work. You will now create such a message.  

14. In the Project Explorer, right-click the User-Defined Screens folder and then select New Popup.  
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15. Rename the new popup Access_Denied or similar.  

 

16. Double-click the popup.  

 

The popup is displayed in the main work area.  
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17. Resize and edit the popup appropriately.  

 

18. Double-click the Home screen to open the screen tab in the main work area.  

 

19. Select the Dashboard button.  

 

20. Select the Events tab.  

 

21. Add a new Button Behavior event.  
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22. In the Choose Behavior dropdown list, select Open popup on release.  

 

23. In the Popup field, select User-Defined Screens > Access_Denied (or whatever you named the 

popup).  

 

24. Verify and save the project.  

25. Download the project to the HMI.  

26. On the HMI, press the Dashboard button. 
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Since you are not logged in as an administrator, the popup is displayed.  

 

27. Click the X button to close the popup.  

28. Log in as the administrator. Click the dashboard button and ensure that you have access to the 

dashboard screen.  

7. Summary and Next Steps 

You have now completed Section 4: The HMI. As you go through the rest of the sections, you will add 
more and more elements to your project’s HMI screen. For example.  

• In Section 5, you will add items that help users monitor sensors.  

• In Section 6, you will implement elements that allow the operators to see if a product has 
passed or failed quality control.  

• In Section 7, you will design and integrate screens and controls for the customer.  

Furthermore, the HMI screen (combined with the PLC program) only runs and monitors three jobs. 
When you work on your project application in earnest, you will need to implement a way to run and 
monitor all jobs used in the application.  

8. Authentic Skill Assessment 

Have your instructor verify that your work meets the requirements in the performance objectives and 
sign below. Keep this lab activity sheet for future reference. 

Instructor Signature Date 

  

9. Shutdown  

Unless instructed otherwise by your instructor, review and complete each of the items on the checklist 
below. 

 Ensure the pendant mode key is in Teach mode.  

 Return the pendant to its storage hook on the side of the SmartCart. 

 Power down the robot. 

 Turn off the air compressor.  

 Power down the I/O box. 

 Close Logix Designer and View Designer. 
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10. Appendix: Updating HMI Firmware 

Perform these steps if your HMI is new and out-of-the-box: 

1. Ensure that your workstation and the HMI screen are connected to the switch via Ethernet 

cables.  

2. Power on the I/O box. The HMI powers on and the Welcome dialog box is displayed. 

 

3. Press Configure the Ethernet Network.  

4. The Internet Protocol (IP) Settings are displayed. Press Manually configure IP settings.   

5. Press the IP address and change it to 192.168.0.4. Press OK to confirm the changes.  

6. Set Subnet Mask to 255.255.255.0.  

7. Press the X button to exit the Network settings. 

8. On your workstation, open Windows Command Prompt. Ping 192.168.0.4 and confirm network 

connectivity. Troubleshoot your LAN setup if the ping was unsuccessful. 



  
 

46 

 
 

Robotics, Integration, and Automation|Building the SmartCart Interface 

 © 2023 Intelitek Inc. All rights reserved | RAI_4-2_Building_HMI_v1.71 

 

9. From the Windows Start menu, open ControlFlash Plus. This utility is installed automatically with 

the Studio 5000 package.  

 

The ControlFlash Plus window is displayed.  
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10. Click the network button.  

 

11. Browse to and select your PanelView HMI. Click OK.  
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The device is displayed in the Flash Devices tab. Note the firmware version in the device and the 

version that is to be flashed.  

 

12. Select the HMI.  

 

13. At the bottom-right corner of the window, click Next.  
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14. Click Flash.  

 

15. Wait patiently as the HMI is flashed. The HMI screen itself displays an Updating firmware 

message. 
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16. When the firmware update is completed, the Flash Results dialog is displayed. Click Close.  

 

17. Click Done. 

 

18. Exit ControlFlash Plus.  

19. Continue to section 6.2 Creating a New Project on page 3. 


